Site Tools


Sidebar


News:


Cartes du Ciel is free software released under the terms of the
GNU banner GNU General Public License


Hosted by SourceForge.net

Support This Project


en:documentation:installation_on_mac_os_x

Installation on Mac OS X

Prerequisites

  • A recent Mac with Intel processor, PPC processors are not supported at the moment.
  • Mac OS X 10.6 or better.


Instructions to install the binaries on Mac OS X.

  • Download the install file, i.e. skychart-3.1-i386-macosx.dmg
  • Open the file to mount the virtual disk.
  • The disk folder opens, it contains the package installer skychart.pkg.
  • Right click the package icon, select Open and follow the instruction to install the software. Depending on your security setting you may have to accept that the package is unsigned. Read more information about Gatekeeper
  • You can now umount the virtual disk (drag to the trash).

Start the program

  • Open the Applications - Cartes du Ciel folder.
  • Open the “skychart” icon.

Options

Telescope drivers

The INDI drivers are required to drive the telescope. Look at this page to know if your telescope is supported.

The simplest way is to install the Indiserver package for Mac OS X available from http://www.cloudmakers.eu/xindi

Wine

Wine is required to compute the artificial satellites position in the Calendar.

The easiest way is to install a pre-build package available from https://dl.winehq.org/wine-builds/macosx/download.html
See also http://wiki.winehq.org/MacOSX

DOSBox

If you also want the Iridium flare prediction with the satellites pass you need to install the DOSBox software.

  • Download the DOSBox dmg from: http://www.dosbox.com/download.php?main=1
  • Install in /Applications
  • To let Skychart use it, copy the binary file to a location in you PATH, for example the same location as Wine above. Be sure to rename the file with all lowercase letter when you do the copy:
    sudo cp /Applications/DOSBox.app/Contents/MacOS/DOSBox /opt/local/bin/dosbox
  • To test, type dosbox from a terminal.

Video recording

Video recording requires the ffmpeg software.

You can install the OS X version from http://www.ffmpeg.org/download.html

en/documentation/installation_on_mac_os_x.txt · Last modified: 2017/07/02 11:48 by pch